Strona 2 z 2

Windows XP UPD 05.2019

: 03 wrz 2019, 23:24
autor: urban92
To zależy jaki PIII. Taki Katmai 500Mhz jest idealny do 2K, ale na moim wykręconym Tualatinie do 1,6Ghz Windows 2000 jest już trochę za stary. A najszybsze Athlony XP Barton wykręcone do ponad 2Ghz w superpi zbliżają się do Athlona 64. Brak SSE2 jednak dyskwalifikuje te procesory obecnie do jakiegokolwiek użytkowania innego niż zabawa retro softem i grami.

Po prostu trzeba stworzyć osobną dystrybucję zaktualizowanego XP dla komputerów bez SSE2.
Przykładowo Firefox także porzucił SSE2 w wersji 49, więc nawet nie można pobrać tam najnowszego - obecnie i tak już starego - FF52ESR
Na tego typu szrotach pakuję zazwyczaj Pale Moon 26.5.0 przeportowany na SSE. Jest o wiele szybszy niż ociężały FF. Przy okazji jest to ostatnia przeglądarka jaka zadziała na Longhornie 4074 w trybie zgodności z XP.

https://1drv.ms/u/s!AoHmPxMSLzPQl5Bhhlb ... A?e=D1wQX0

Windows XP UPD 05.2019

: 04 wrz 2019, 8:22
autor: WinSxS
Wczoraj trochę się pobawiłem P4, poszukałem pewnych aplikacji..
Dobrą alternatywą jest ostatnia wersja Maxthona (beta), oparta na dosyć nowym Chromium (bodajże 68 lub 69). Ta przeglądarka w parze z zaaktualizowaniem certyfikatów TLS wyświetla praktycznie 99% stron, w tym niebezpiecznik.pl, który domyślnie na XP już nie chce odpalić na Chrome czy Operze.

https://msfn.org/board/topic/175170-roo ... nt-1110568

Windows XP UPD 05.2019

: 04 wrz 2019, 11:19
autor: urban92
Ale to wszystko pod SSE2. Wsparcie dla procków bez SSE2 kończy się na Pale Moon 26 / FF ESR 45. Ostatnia wersja webkita która nie wymaga SSE2 jest już masakrycznie stara (Chrome 26).

Nie jest problemem dobudować do silnika webkit interfejs zgodny z API XP, problemem jest przekompilować webkita na SSE, co jest niemożliwe i bez sensu. Ten silnik jest zbyt ociężały na starsze procesory. Tualatina zabije wyświetlenie głównej strony Facebooka.

Oczywiście nieśmiertelna Opera 12.18 zadziała na wszystkim i wciąż zadziwiająco dobrze radzi sobie z wyświetlaniem stron.

Windows XP UPD 05.2019

: 08 wrz 2019, 20:46
autor: funcek
New Moon w wersji 27 też już nie działa na prockach bez SSE2?
Nie mam sprzętu bez SSE2 na XP. Na 2k, z oczywistych względów, nie działa.

Windows XP UPD 05.2019

: 08 wrz 2019, 22:27
autor: urban92
New Moon w wersji 27 działa, wersji 28 już nie da się skompilować bez SSE2.

Ostatnia działająca kompilacja:
http://rtfreesoft.blogspot.com/2018/08/ ... 80818.html

Co ciekawe problem nie dotyczy linuxa gdzie mogę sobie skompilować wszystko nawet na i386 i z powodzeniem używałem najnowszej wersji Firefox 69 na Lubuntu 16.04 zainstalowanym na Tualatinie.

Nie dotyczy to jednak webkita który jest totalnie nieelastyczny i wszystkie przeglądarki oparte o webkita wywalają się, co ciekawe webkit porzucił 32 bitowe linuxy prawie rok temu i ani Chromium ani Opera nie aktualizują się już na 32 bitowych linuksach.

Windows XP UPD 05.2019

: 08 wrz 2019, 23:30
autor: funcek
Nie dotyczy to jednak webkita który jest totalnie nieelastyczny i wszystkie przeglądarki oparte o webkita wywalają się, co ciekawe webkit porzucił 32 bitowe linuxy prawie rok temu i ani Chromium ani Opera nie aktualizują się już na 32 bitowych linuksach.
O, a ja byłem pewien, że to kwestia nieaktualnych repo SliTaz'a. :P