Strona 1 z 1

Problemy z GRUBem

: 01 lis 2013, 20:49
autor: Conrado967
Witam

Mam problem, który polega na tym, że po instalacji Linuxa (testowałem dotychczas Xubuntu i Minta) grub wykrywa mi Windowsa, ale nie potrafi go zbootwać. Zamiast tego wyświetla mi się komunikat: disk error occurred press ctrl alt del to restart (co ciekawe wówczas nawet klawiatura mi nie działa). Wiem, że Windows jest w porządku bo po nadpisaniu MBR wywala GRUBa i system Microsoftu normalnie się uruchamia. Oto mój układ partycji:
Urządzenie Rozruch Początek Koniec Bloków ID System
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT (Zastrzeżone przez system)
/dev/sda2 206848 204902399 102347776 7 HPFS/NTFS/exFAT (Windows 7)
/dev/sda3 204904446 1953523091 874309323 f W95 Rozsz. (LBA)
Partycja 3 nie zaczyna się na granicy bloku fizycznego.
/dev/sda5 204904448 1933988432 864541992+ 7 HPFS/NTFS/exFAT (Dane)
/dev/sda6 1933989888 1953523091 9766602 83 Linux

Od razu pisze, że sudo update-grub2 nie pomaga. Gdyby to miało jakieś znaczenie to:
Generowanie grub.cfg...
Found linux image: /boot/vmlinuz-3.8.0-26-generic
Found initrd image: /boot/initrd.img-3.8.0-26-generic
Found memtest86+ image: /boot/memtest86+.bin
No volume groups found
Znaleziono Windows 7 (loader) na /dev/sda1

I jeszcze wpis z gruba:
insmod ldm
insmod ntfs
set root='ldm/9d8cc2fc-17d4-11e3-9f98-001966905002/Volume1'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0 --hint-efi=hd0 --hint-baremetal=ahci0 --hint='ldm/9d8cc2fc-17d4-11e3-9f98-001966905002/Volume1' 9640587440585D55
else
search --no-floppy --fs-uuid --set=root 9640587440585D55
fi
chainloader +1


Pewnie można łatwo zauważyć, że nie jestem za bardzo obeznany z Linuxem, ale od czegoś trzeba zacząć więc nie linczujcie od razu.

Re: Problemy z GRUBem

: 01 lis 2013, 22:31
autor: Onset
Prościej chyba będzie użyć EasyBCD i dodać Nim wpis do BCD, przez który uruchomisz GRUB-a bootmanagerem 7. :)

Re: Problemy z GRUBem

: 02 lis 2013, 9:00
autor: miki100
Wygląda na to że dopadł cię ten bug: https://bugs.launchpad.net/ubuntu/+sour ... ug/1061255.
Spróbuj dodać do /etc/grub.d/40_custom :

Kod: Zaznacz cały

menuentry "Windows 7" { set root=(hd0,hd1) chainloader +1 }
i odpalić sudo update-grub.

Re: Problemy z GRUBem

: 12 lis 2013, 21:07
autor: Conrado967
@miki100, niestety Twoja porada nie przyniosła rozwiązania.

@Onset, aby dodać wpis do BCD musiałem odzyskać MBR co spowodowało zepsuciem Gruba i przez to po dodaniu wpisu do BCD, wybierając opcję Linuksa pojawia się "Grub rescue", ale wydaję mi się, że wystarczy odzyskać teraz Gruba i wszystko będzie hulać.

Dzięki za pomoc :).

Re: Problemy z GRUBem

: 13 lis 2013, 21:31
autor: Onset
@miki100, niestety Twoja porada nie przyniosła rozwiązania.

@Onset, aby dodać wpis do BCD musiałem odzyskać MBR co spowodowało zepsuciem Gruba i przez to po dodaniu wpisu do BCD, wybierając opcję Linuksa pojawia się "Grub rescue", ale wydaję mi się, że wystarczy odzyskać teraz Gruba i wszystko będzie hulać.

Dzięki za pomoc :).
Dokładnie, przywróć plik konfiguracji GRUB-a. :)